https化に伴うデザイン崩れ

890 views
  1. コメントする
  2. 記事検索
  3. 更新

0
抹茶 SO-01J 2017/11/16 00:34
最近使い始めた初心者のものです。
本当に初歩的なことかもしれないのですが……
https化に伴いデザインが崩れる、というお知らせがあったのは存じていますが、
実際に今まで反映されていたフォントが反映されなくなってしまい、どうすれば良いのかわからず困っています。
HEADの部分をどうにかすればいいのはわかるのですが、どの部分をどうすればいいのかわかりません。
どうかお力添え頂ければ幸いです。
よろしくお願いします。

残り992件書き込み可

8
しち Firefox 2017/11/17 04:24
>>4
改めて確認したら自分のところでもjQueryが機能しなくなっていました。
のでリンク先を参考に、
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
とプロトコル(http:)を省略したところ無事機能しました。(Android版のchrome、Firefox、Sleipnirで確認)

WebフォントはHEADに<link href="https://fonts.googleapis.com/(略)>で貼り付けてたからか表示に変化はなく、そのためjQueryの方には気付いてませんでした…ありがとうございます!
キャッシュクリアとか関係なかったですねすみません(;´ω`)
7
抹茶 SO-01J 2017/11/16 13:02
>>4
度々失礼致します。
先程フォントのプロトコル部分を消したところ元通りになりました!
本当にありがとうございました。

右も左も分からないような私のトピに目を向けお返事を書いてくださった皆様、本当にありがとうございました。
6
抹茶 SO-01J 2017/11/16 12:52
>>4
ありがとうございます。
早速見て直してみます。
本当に助かりました。
5
抹茶 SO-01J 2017/11/16 12:51
>>3
お返事ありがとうございます。
同じような状況の方がいると知り少し安心しました。
4
匿名 iPhone 2017/11/16 10:07
>>3
サイトURLの提示がないので憶測でしか言えませんが
ブラウザが拒否ってるのかも
以下を参照してみてください
https://webmist.info/https-javascript/
http://blog.showzine.co/entry/http_https_css-link

3
ななし iPhone 2017/11/16 09:40
>>0
当方Safariにて閲覧しておりますがトピ主様と全く同じ状況で一部WEBフォントが反映されなくなったのと、使用しているjQueryも効かなくなりました。HEADもCSSも一切触れていないので、トピ主様も症状が改善されない場合はhttps化に伴う何かが原因かもしれません。参考までに。
2
抹茶 SO-01J 2017/11/16 07:12
>>1
お返事ありがとうございます!

御指摘の通り、chromeを使用しています。
HEAD、CSS共にいじった覚えが無いので恐らくその通りだと思います。

わかりづらい質問だったにも関わらずご丁寧に教えて頂き本当にありがとうございます。助かりました。

1
しち Firefox 2017/11/16 06:10
>>0
デザイン崩れに関しては「https化作業中の一時的なもの」としてお知らせに書かれていました。11/14にhttps化完了のお知らせが来ていますが、それ以降もデザインが崩れているということでしょうか?
なおこれはhttpsになるとデザインが崩れる、という意味ではありません。
ですので多分、HEADまたはCSSを弄ったせいか、デザイン編集でフォントを適用させるタグを消してしまったか、ブラウザの仕様か……https化が問題ではないように思われます。

情報不足なのでまずお尋ねしますが、

●フォントというのは、Webフォントでしょうか?
●テンプレをお使いですか?
●HEAD・CSS・デザイン編集のどれかを弄った拍子にフォントが反映されなくなったわけではないのですか?
●サイトを確認するのに使っているブラウザは何でしょうか?もしかしてchromeではありませんか?

なんでchromeかと言うと、chromeはたまにWebフォントを反映してくれなくなることがあるからです。
自分も一度、今まで反映されていたWebフォントが通常フォントになって驚きましたが、キャッシュクリアで無事反映されるようになりました。
あとは通信環境が悪くてWebフォントが読み込まれず代替フォントで表示されているとか……『ブラウザの仕様では?』というのはそういう意味です。(※当方が使用しているのがchromeというだけで、他にもこういう現象が起こるブラウザはあるかもしれません)

#なので一度、ブラウザのキャッシュクリアを行なってみてください。もしくは、別のブラウザから(PCからとかでもいいです)アクセスしてみてください。
それでも反映されていなければブラウザの問題ではないかもしれません。

HEADのどの部分をどうすれば……に関しては、見ないことにはよく分かりません。Webフォントの埋め込み方も色々ありますし、そもそもCSSに書いてあるかもしれないし…。
まあでもHEADやCSSを弄ってないのに反映されなくなった!というのであれば、原因は【デザイン編集】かブラウザの仕様にあるかと思いますが……。
思いつくのはこんなところです。
1ページ中1ページ目

Back to Top