スマホで背景画像が表示されない

224 views
  1. コメントする
  2. 記事検索
  3. 更新

0
かほ iPhone 2019/01/09 23:50
HTML/CSSは多少の知識しかないため、初歩的な質問になるかと思いますが失礼します。

現在、外部のテンプレート配布サイト様のテンプレートをお借りしてサイトを制作しております。

画像URLを指定して表示させたいのですが、PCからはうまく表示されますがスマホからだと表示されません。

サイトの注意事項より独自タグを使用するようにとのことでしたので、##IMAGE_DATA_1_URL##などのタグで記述していますが上手くいきません。
PCからは表示されているので、タグ自体は反映されている風に思います。
また別の枠に同じタグ、##IMAGE_DATA_1##を記述するとURL、画像ともに問題なく表示されました。

これらの記述は全て「トップページ編集」の「トップページ編集枠」に記述しています。

他にも似たような内容の質問スレッドを拝見しましたがそちらは原因が分からないまま解決なさっていたので、改めて質問させて頂きました。
また、テンプレート配布元様に質問した方がいいような問題かどうか判断しかねたため投稿しましたがそのようでしたら改めて本元様へ質問してみます。

分かりにくい文章でしたらすみません。よろしくお願い致します。

残り997件書き込み可

3
しち Firefox 2019/01/11 00:01
>>2
無事解決とのこと、よかったです!

うっかり>>1で書き忘れたんですが、ナノ⇔ALICE+では「表記が同じだけど影響範囲が異なる端末別表示タグ」が多くて……
『PCとスマホのみ表示』タグがあるテンプレなら、『携帯のみ表示』タグも使われてたりしないかな……と今更気になってしまったのですみません、書き込みます。
問題ナシ・すでに対処済みでしたら更にすみません。無視してください…
(同種の問題でスレを検索した人向けに、一応書いておこう……という奴です)

『携帯のみ表示』タグは、ナノだと<nopc></nopc>。
>→ALICE+では <mobile></mobile>
です。ALICE+で nopc は『携帯とスマホのみ表示』なので、まあPCとスマホに表示差異がなければ使われていない……はずです。

どっかで使った端末別表示タグ対照表をついでに置いていきます。
800×536PNG
49KB

2
かほ iPhone 2019/01/10 14:54
>>1
ご回答ありがとうございます

言われたようにheadとトップページ編集枠で<pc></pc>のタグを探すとその記述があり、<nomb></nomb>に書き換えると無事に表示されました
ありがとうございます……!

しち様の言う通り配布元様はナノを使い運営されており、わたし自身も最近ナノからこちらに移行してきたのでタグの違いに気付かなかったようです
ご丁寧な解説、ありがとうございました
1
しち Firefox 2019/01/10 02:22
>>0
一読した限り【CSSファイル編集】は不使用とお見受けしましたが、いかがでしょうか。もしも編集したのが【トップページ編集】や【○○head間編集】だけでしたら思いつく原因は、「端末別表示のタグが間違っている」、などでしょうか。

外部のテンプレ配布サイトさんとのことですが、もしかしてナノさん仕様のテンプレだったりしませんか?

もしそうなら、そのテンプレ内に
>  <pc> </pc>
といった独自タグが入っていたりしませんか?
もしあれば、それをそれぞれ
#  <pc>→  <nomb>
#  </pc>→ </nomb>
に書き換えてください。
これは“端末別表示のタグ”といって、閲覧者の使用している環境(=端末)によって表示するものを変えられる……という独自タグです。

確認場所は
*HTML(【トップページ編集】の『トップページ編集枠』)と、
*head(【共通head間編集】または【トップページhead間編集】)です。
お使いになっている編集枠全部確認してください。

ナノの場合、この <pc></pc> に括られたものは「PCとスマホのみ表示」されるのですが、
ALICE+さんの場合は 「PCのみ表示」 になるんですね。

ナノ仕様のテンプレを流用していて、「PCでは表示されるのにスマホで表示されない」系の不具合は大体これのような気がします。

これじゃない場合はHTMLなりCSSなりを見ないと問題箇所の推測が難しいです。
HTML・CSS側の問題である可能性もあるにはありますし。ほか、コピペミスとか……。

……あと自分もテンプレ配布側なので、余計なお世話承知で書き添えておきますと……
配布元さんがALICE+経験者でない場合は、この手の質問をされても対応が難しいかもしれません。HTML・CSSの問題なのか、ブラウザの問題なのか、ALICE+の仕様に合った構造でないのが問題なのか、読んだ限りでは判断できない感じなので……。
1ページ中1ページ目

Back to Top